Zur Strippenstrolch-Homepage

Forum Strippenstrolch

Forums-Ausgangsseite

log in | registrieren

zurück zum Board
Thread-Ansicht  Reihenfolge
strolch(R)

Homepage E-Mail

Sassenburg,
31.10.2019, 16:23
 

Benutzerverwaltung @ Admin-Bereich (Fehlermeldungen @ Software)

Beim Versuch, die Nutzerdaten zu editieren erhalte ich diese Fehlermeldeung, wenn ich das Formular abschicken möchte:

[image]

---
Beste Grüße,

Stephan Mischnick

Auge(R)

01.11.2019, 10:16

@ strolch

Benutzerverwaltung @ Admin-Bereich

Hallo

>> Beim Versuch, die Nutzerdaten zu editieren erhalte ich diese
>> Fehlermeldeung, wenn ich das Formular abschicken möchte:
>>
>> [image]

Die Meldung wird angezeigt, wenn du die Daten nach der Bearbeitung speichern willst?

Tschö, Auge

---
- My Github account

strolch(R)

Homepage E-Mail

Sassenburg,
01.11.2019, 10:47

@ Auge

Benutzerverwaltung @ Admin-Bereich

>> Hallo
>>
>> >> Beim Versuch, die Nutzerdaten zu editieren erhalte ich diese
>> >> Fehlermeldeung, wenn ich das Formular abschicken möchte:
>> >>
>> >> [image]
>>
>> Die Meldung wird angezeigt, wenn du die Daten nach der Bearbeitung
>> speichern willst?
>>
>> Tschö, Auge

Ja genau.

==> Ich wollte einen guten Freund (Elektroniker) zum Moderator machen, damit er seine Texte besser editieren kann und habe nur den entsprechenden Radio-Button angeklickt. Danach wollte ich das absenden, dabei ist die Fehlermeldung aufgetreten.

Beschädigt wurde aber nichts.

---
Beste Grüße,

Stephan Mischnick

Auge(R)

01.11.2019, 11:30

@ strolch

Benutzerverwaltung @ Admin-Bereich

Hallo

>> >> >> [image]
>> >>
>> >> Die Meldung wird angezeigt, wenn du die Daten nach der Bearbeitung
>> >> speichern willst?
>>
>> Ja genau.
>>
>> ==> Ich wollte einen guten Freund (Elektroniker) zum Moderator machen,
>> damit er seine Texte besser editieren kann und habe nur den entsprechenden
>> Radio-Button angeklickt. Danach wollte ich das absenden, dabei ist die
>> Fehlermeldung aufgetreten.

Ich kann den Fehler in meinem Testforum nachvollziehen. Wenn ich meinen eigenen Datensatz (selbst ohne Änderung) speichern will, erscheint die Fehlermeldung.

Ich werde da rein schauen.

Tschö, Auge

---
- My Github account

strolch(R)

Homepage E-Mail

Sassenburg,
01.11.2019, 11:58

@ Auge

Benutzerverwaltung @ Admin-Bereich

>> Ich kann den Fehler in meinem Testforum nachvollziehen. Wenn ich meinen
>> eigenen Datensatz (selbst ohne Änderung) speichern will, erscheint die
>> Fehlermeldung.
>>
>> Ich werde da rein schauen.
>>
>> Tschö, Auge

1000 Dank. :-)

Lass dir bitte Zeit, es eilt nicht. :ok:

---
Beste Grüße,

Stephan Mischnick

Auge(R)

04.11.2019, 09:23

@ strolch

Benutzerverwaltung @ Admin-Bereich

Hallo

>> >> >> Beim Versuch, die Nutzerdaten zu editieren erhalte ich diese
>> >> >> Fehlermeldeung, wenn ich das Formular abschicken möchte:
>> >> >>
>> >> >> [image]
>>
>> ==> Ich wollte einen guten Freund (Elektroniker) zum Moderator machen,
>> damit er seine Texte besser editieren kann und habe nur den entsprechenden
>> Radio-Button angeklickt. Danach wollte ich das absenden, dabei ist die
>> Fehlermeldung aufgetreten.
>>
>> Beschädigt wurde aber nichts.

Ich habe den Fehler gefunden. Damit du weiter machen kannst, gehe in einem qualifizierten Texteditor (der Windows-eigene Editor gehört meiner Meinung nach nicht dazu) in die admin.php zur Zeile 356, in der der Datenbank-Query zum speichern der Benutzerdaten zusammengesetzt wird. Der letzte zu speichernde Wert ist die Spalte "time_difference". Mache auch:

... time_difference=". intval($user_time_difference) ."' WHERE user_id ...


... time_difference=". intval($user_time_difference) ." WHERE user_id ...



Beachte das einfache Anführungszeichen vor WHERE.

In meiner Testinstallation konnte ich danach im Admin-Bereich wieder Benutzerdaten speichern. Ich werde außer der Reihe eine neue Version fertig machen (1.7.9). Logischerweise wird der Fix auch in die 1.8 einfließen.

Tschö, Auge

---
- My Github account

strolch(R)

Homepage E-Mail

Sassenburg,
04.11.2019, 09:56

@ Auge

Benutzerverwaltung @ Admin-Bereich

Mache auch:
>>
>>

... time_difference=". intval($user_time_difference) ."' WHERE
>> user_id ...


>>

... time_difference=". intval($user_time_difference) ." WHERE user_id
>> ...


>>
>> Beachte das einfache Anführungszeichen vor WHERE.
>>

Dankeschön.

Ich kann das erst gegen 19:00 Uhr durchführen.
Ich melde mich dann.

---
Beste Grüße,

Stephan Mischnick

strolch(R)

Homepage E-Mail

Sassenburg,
04.11.2019, 18:29

@ Auge

Benutzerverwaltung @ Admin-Bereich

>>

... time_difference=". intval($user_time_difference) ."' WHERE
>> user_id ...


>>

... time_difference=". intval($user_time_difference) ." WHERE user_id
>> ...



Hat geklappt, funktioniert jetzt.

Besten Dank. :ok:

---
Beste Grüße,

Stephan Mischnick

zurück zum Board
Thread-Ansicht  Reihenfolge
6120 Postings in 815 Threads, 5 registrierte User, 15 User online (0 reg., 15 Gäste)
Forum Strippenstrolch | Kontakt
RSS Feed
powered by my little forum