Betreiber dieses Archivs (Impressum)

Forum Strippenstrolch (Archiv)

Forums-Ausgangsseite

Board-Ansicht

Benutzerverwaltung @ Admin-Bereich (Fehlermeldungen @ Software)

verfasst von Auge(R), 04.11.2019, 10:23

Hallo

>> >> >> Beim Versuch, die Nutzerdaten zu editieren erhalte ich diese
>> >> >> Fehlermeldeung, wenn ich das Formular abschicken möchte:
>> >> >>
>> >> >> [image]
>>
>> ==> Ich wollte einen guten Freund (Elektroniker) zum Moderator machen,
>> damit er seine Texte besser editieren kann und habe nur den entsprechenden
>> Radio-Button angeklickt. Danach wollte ich das absenden, dabei ist die
>> Fehlermeldung aufgetreten.
>>
>> Beschädigt wurde aber nichts.

Ich habe den Fehler gefunden. Damit du weiter machen kannst, gehe in einem qualifizierten Texteditor (der Windows-eigene Editor gehört meiner Meinung nach nicht dazu) in die admin.php zur Zeile 356, in der der Datenbank-Query zum speichern der Benutzerdaten zusammengesetzt wird. Der letzte zu speichernde Wert ist die Spalte "time_difference". Mache auch:

... time_difference=". intval($user_time_difference) ."' WHERE user_id ...


... time_difference=". intval($user_time_difference) ." WHERE user_id ...



Beachte das einfache Anführungszeichen vor WHERE.

In meiner Testinstallation konnte ich danach im Admin-Bereich wieder Benutzerdaten speichern. Ich werde außer der Reihe eine neue Version fertig machen (1.7.9). Logischerweise wird der Fix auch in die 1.8 einfließen.

Tschö, Auge

---
- My Github account

 

gesamter Thread:

zurueck zum Forum
Board-Ansicht
6120 Postings in 815 Threads, 5 registrierte User, 22 User online (0 reg., 22 G?ste)
Forum Strippenstrolch (Archiv) | Kontakt
RSS Feed
powered by my little forum